Topic: How to get normal map to work

Hi. The exporter script is working fine, however normal mapping is not showing up with the generated entitys. I am using blender 2.62, the script is 2.57.

EDIT: it works now, but the normap map is inverted.

Last edited by chimp (2012-04-01 20:54:07)

Re: How to get normal map to work

is it also inverted in blender ? how did you do the normal map ?
With an image software (gimp, photoshop) you might try to reverse the texture's red and green components.

Re: How to get normal map to work

Hi, i tested a small room with textures from evil lair: … ;Itemid=43
Its the last one, named eX.

The texture normals on the floor are inverted, on the wall not. Maybe theres something with the normal map, or i have forgotten to check the normal map option in blenders texture settings. Is the normal mapping in a standard material world space when this box is unchecked?

Re: How to get normal map to work

Thank you,
I'll try to have an eye at it, it can be a difference in the way maratis uses normal map.

Re: How to get normal map to work


so I made a quick test with the textures you linked,
for me it's working good, but at some point I taught something was wrong,
and in fact I exported a room with bad normals :

- check that your normals are not flipped in blender (use "flip" button or "calculate outside" to be sure)
- enable the "smooth" shading in blender to visualize the real normals (don't use the flat mode).
- and then be sure you are applying the "edge split" modifier to have clean smoothing groups.

It can also be that your UV mapping is reversed in x or y for the floor.

Tell me if it works, and I'll investigate more on this topic.