Re: Call for contribution : we need you !

Maybe the compiler need to be set to compile for all platforms, i dunno. Made some new vid: …

Re: Call for contribution : we need you !

i'm testing the new version for windows x64
edit: so it's apparently the same  as win32 , and i don't see a need  for uploading a new version

Last edited by ulbex (2014-08-17 14:08:08)

Re: Call for contribution : we need you !

I tested the latest version of Maratis on Mac OS X 10.6 Snow Leopard on a IMac Aluminum 7,1 has a ATI Radeon HD 2400 XT chipset.

Last edited by zester (2014-09-12 22:12:46)

Re: Call for contribution : we need you !

Thanks zester, did it run ?

Re: Call for contribution : we need you !

anael wrote:

Thanks zester, did it run ?

Yes it ran and worked just fine. I didn't test running any scripts just played with the editor(Models, Lights, ...). This machine is new to me and only has 1GB of RAM, I need to upgrade to 6GB RAM and do a triple boot Mac, Linux, Windows. Hoping it will be able to function as a build bot for all platforms.

Re: Call for contribution : we need you !

some tests for the win32 version :

Set parent to 0 = Ok

Performance = Very big improvement on the loading time, on previous versions i had to wait about 15secs (sometimes even more) for maratis to load, now it is about 4sec and in some cases, it instant-load. thumbs up !

Light Color tweaking = Ok
Text Color tweaking = Ok

Gravity  :
Tweaking the gravity in the editor = Ok
Tweaking the object mass in the editor : doesn't change anything, the object always fall at the same speed in game

Re: Call for contribution : we need you !

Thank you zester and Vegas !

Vegas :

Tweaking the object mass in the editor : doesn't change anything, the object always fall at the same speed in game

It's normal, in reality all objects fall at the same speed, they are just slowed down by air friction depending on their shape, not their mass. That's why in the moon (no air) an iron ball and a feather hit the ground at the same time.

Re: Call for contribution : we need you !

Linux 64 : bryce : link

The link does not work, sad  where can I download it?

Re: Call for contribution : we need you !

ant0n you can try using building it by following the instruction and getting the latest release

Re: Call for contribution : we need you !

Actually, the last Maratis-3x is still there :

The link given by damvcool is for Maratis-4x (experimental and in-progress)

Re: Call for contribution : we need you !

I did for Linux x64 because the other links do not work.

Re: Call for contribution : we need you !

I compiled a version for Windows 32-bit. It's based on the most recent version of Maratis from the archive on Google Code (Commit 243):

You can download it here: … sp=sharing

I haven't had time to test it thoroughly.

I compiled it on Windows 10 Pro 64-bit with a 64-bit processor, but the "SCons" tool still decided to compile the 32-bit version!

I spent all day trying to compile a 64-bit version for Windows, but I must admit my inadequacies by sleeping now. Hahaha. I will try again tomorrow.

I have these versions of Visual Studio installed:

1: Visual Studio 2010 Express (I read that the "Express" versions cannot compile 64-bit programs unless the SDK is used, and I don't know if the automatic process of SCons can use the SDK.)
2: Visual Studio 2013 Community
3: Visual Studio 2017 Community

I tried many ideas, like editing the SCons files to search for MSVC 12.0 (version 12.0 is actually Visual Studio 2013), and SCons always says that version 12.0 isn't installed! Version 11.0 is detected as installed, even though that number is for Visual Studio 2012 and I DON'T have that installed. As a test, I set the MSVC section of the SCons file to "11.0", and then I changed the option that said "x86" to "x86_64", and the compilation always showed an error similar to "CL not found".

This is the order of my actions:

1. I only had Visual Studio 2017 installed and I couldn't compile it.

2. Then, I installed Visual Studio 2010, and it compiled during the first try.

3. Then, I installed Visual Studio 2013 because I read that the Express versions cannot normally compile 64-bit files, and since Visual Studio 2017 wasn't working (even though it's not an Express version), I needed to move to an older version that can compile 64-bit files with their free versions. Those are called "Community", and the oldest community version is for Visual Studio 2013, so I installed it. I haven't tried to compile a 32-bit version again, so I don't know if installing VS 2013 ruined that process.

Last edited by wild master (2017-12-08 14:46:38)

Re: Call for contribution : we need you !

I also tried to set the "TARGET_ARCH" of SCons to "amd64” and I receive the same error that says " 'CL' is not recognized as an internal or external command, operable program or batch file". That error doesn't happen if I set the "TARGET_ARCH" back to "i386". I wonder if more complex changes must be done to the SCons files before it can compile a 64-bit version of Maratis. I searched for that error on google and many people said the location of the "cl.exe" file must be added to the system PATH environment variable in the SCons files, but I don't know how to do that. The official documentation for SCons is very confusing.

After that, I noticed that a project file for Visual Studio 2010 is included in the source files of Maratis, so I decided to try it, even though a text file says it might not be up to date.

Visual Studio 2010 doesn't include a 64-bit compiler in the Express version, but a free SDK enables 64-bit compilation, so I installed it. Then I opened the project file for Visual Studio 2010, and I fixed many of the compilation errors, but the last few are bothering me.

In Vusual Studio 2010, the part called "MCore" compiles successfully, but when compiling the part called "MEngine", it says a file called "MLog" is missing.

In the Solution Explorer, I see a file called "MLog" and a file called "MLog.h". With a normal file manager, I checked all directories for a file called "MLog" without a file extension, but it doesn't exist. Since this seems like a user error, I deleted "MLog" from the Solution Explorer and added "MLog.cpp" in the same place (and with the same properties) that the "MLog" item had.

Then, I tried compiling MEngine again, and I see this error:

..\..\MSDK\MEngine\Sources\MLog.cpp : fatal error C1033: cannot open program database 'c:\maratisvs2010\trunk\dev\projects\visualstudio2010\release\vc100.pdb'

(I wasn't lazy. Visual Studio displays the file location with all lowercase letters.)

Microsoft's documentation says that error C1033 might be a file disk error, possibly related to multi-byte characters in the directory path: … .100).aspx … rror-c1033

The "Maratis" and "MaratisPlayer" parts of the project almost compile correctly. Only two errors appear for each of them, and they are the same for both: It complains of one missing file called "Bullet-C-API.cpp" that actually doesn't exist in Anaël's source files, and it shows this error about a file named MWin32Window.cpp:

..\..\MSDK\MGui\Sources\WIN32\MWin32Window.cpp(961): warning C4090: '=' : different '__unaligned' qualifiers

Do any of you have advice for fixing these few errors?

Is my assumption about the "MLog" file correct, or is a file called "MLog" without a file extension actually supposed to be in the source files?

Last edited by wild master (2017-12-06 14:26:56)

Re: Call for contribution : we need you !

I don't support Maratis3x sources anymore but here I updated the project for visual studio 2012:

Still x86 but it should not be hard to compile in x86-64 mode.

Re: Call for contribution : we need you !

I installed "Visual Studio 2012 Express for Windows Desktop" and I tried to compile Maratis for Windows x64, but the build was unsuccessful, and I was terrified of the compilation warnings. I researched the errors, but I couldn't comprehend the advice that I found because I don't know how to modify the source code to convert some of the parts to x64.

I'll abandon that pursuit and use the 32-bit version that I compiled for Windows to finally start designing my game.

As a consolation, I compiled the 32-bit version for Linux! I quickly opened it with Lubuntu 14.04 for i386 and it worked after I installed a package called "libopenal1" with Synaptic Package Manager.

Get it here: … sp=sharing

Last edited by wild master (2017-12-08 15:34:08)